System requirements

The minimum hardware needed to work in Apache Royale

Apache Royale is designed for use on Mac or PC computers. We would love to know your experience with it on a Linux machine!

Since developers often use Royale in the IDE of their choice, the system needs to satisfy the minimum requirements for that IDE. You do not need Internet access to work with Royale unless that is required by the IDE you are using. Royale provides scripts you can run if you want to compile your application using the command line, without an IDE.

Royale requires Java SDK 1.7 or greater to be installed on your computer. You can access the latest Java SDK from the Java download site.